QBO Sync Error - "The account period has closed and the account books cannot be updated through the QBO Services API."

Modified on Mon, 06 Mar 2023 at 01:35 PM

QBO Sync Error - "The account period has closed and the account books cannot be updated through the QBO Services API. Please use the QBO website to make these changes."

Cause


The invoice is dated for a closed period in QBO and the invoice cannot post to this month. This can happen when you receive an invoice late and happen to have closed the previous period.

Resolution

You have a few options to correct this sync error. Pick whichever makes the most sense for your bookkeeping.

Option 1: Reopen the month in QBO then reset the invoice in Beanworks and re-export the invoice to QBO again, once the invoice is fully approved.

Option 2: Reset the invoice in Beanworks and change the invoice date to the open month in QBO. Once the invoice is fully approved again export to QBO. The invoice will post to the open period rather than the previously closed period. 


Was this article helpful?

That’s Great!

Thank you for your feedback

Sorry! We couldn't be helpful

Thank you for your feedback

Let us know how can we improve this article!

Select atleast one of the reasons
CAPTCHA verification is required.

Feedback sent

We appreciate your effort and will try to fix the article